Ein Plotter für wenig Geld

Günstig gekauft, selbst repariert und Geld gespart

Ich bin ja gelernter Mediengestalter und habe eigentlich meine Ausbildung im Fachbereich digital gemacht. Davor habe ich aber einige Praktika in kleinen, klassischen Werbefirmen gemacht und habe dort Logos, Firmenschilder und Fahrzeugbeschriftungen entworfen und auch bei der Produktion und Montage mitgewirkt.

Vor kurzem hatte ich dann mal wieder Lust, mich damit noch einmal zu beschäftigen. So hatte ich die verrückte Idee, mir einen Plotter zu besorgen und selbst Aufkleber zu produzieren. Das blöde ist: Die Dinger kosten selbst gebraucht noch ordentlich Asche. Zwar gibt es inzwischen auch kleinere Modelle für den Hobbygebrauch, aber die können oft nicht viel größeres als DIN A4 verarbeiten. Da ich aber eventuell ein wenig Werbung für meine Seite auf mein Auto bringen möchte, brauchte ich eine Nummer größer.

Also habe ich eBay gezielt nach defekten Plottern durchsucht, in der Hoffnung, etwas zu finden, wo einfach nur eine Kleinigkeit kaputt ist. Vielleicht ein Netzteil durchgebrannt oder sowas. Und wenn doch die Steuerung komplett hin ist, dann ist so ein Plotter einem 3D-Drucker ja gar nicht so unähnlich. Dann halt einfach irgendwas neues auf Arduino-Basis, wie ein MKS Mainboard, reingeklatscht, am besten noch leiste Trinamic Treiber dazu und fertig ist der Lack.

Die Suche nach dem perdefekten Plotter

Leichter gesagt als getan. Da werden auf eBay echt Plotter angeboten, die im Paket mit einem Mac aus den frühen Neunzigern kommen, auf dem die Software läuft. Und selbst defekte Geräte mit unbekannten Problemen gehen für viel Geld weg oder werden zwar günstig verkauft, aber nicht versendet. Artikelstandort: 400km entfernt :-/

Andererseits spricht die Situation ja auch für sich: Gute Maschinen sind offenbar echte Arbeitstiere und werden in kleinen Firmen auch über 20 Jahre nach der Anschaffung noch täglich genutzt. Über Monate habe ich am Ende immer wieder alles abgesucht. Wilde Filterkombinationen probiert um unentdeckte Perlen zu finden und auch manches Mal mitgeboten – leider ohne Erfolg.

Irgendwann fiel mir dann aber doch ein Gerät mit niedrigem Startpreis und wenigen Geboten auf. Versand wurde für Überschaubares Geld angeboten. Den offenbar chinesischen Hersteller Creation und das Modell Pcut CT-630 kannte ich bis dato noch nicht, aber davon wollen wir uns nicht abhalten lassen. Die Artikelbeschreibung war leider auch nicht sehr vielsagend:

schneideplotter pcut. Zustand: Als Ersatzteil / defekt. Versand mit DHL Paket bis 31,5 kg. 
Am Schluss funktionierte er nicht mehr. Was genau dran ist kann ich nicht sagen. Wir holten dann einen neuen. 

Quelle

Aber wenn der Preis stimmt, ist es das Risiko wert. Vielleicht war der Verkäufer bei der Fehlersuche ja genau so faul, wie bei der Angebotsbeschreibung. Irgendwie bekommt man das Ding schon zum Laufen.

Langer Rede kurzer Sinn: Einige Tage später hat die Post ein recht großes und schweres Paket an unsere Haustür gebracht (An dieser Stelle herzlichen Dank an unsere fleißige Postbotin. Leider waren an dem Tag noch einige andere Pakete für mich dabei). Um die 70€ inkl. Versand hat mich mein neues Spielzeug am Ende gekostet. Nicht schlecht finde ich!

Lese auch:  Energiekette für den Tevo Tornado

Erster Test und Fehlersuche

Bei einem ersten Test zeigte sich schonmal: Das Netzteil scheint in Ordnung, der Plotter ging an und das Display zeigte etwas. Nur bewegt hat sich nichts. Nach einer kurzen Lektüre des Handbuchs hatte ich auch die nicht ganz so intuitiven Bedienelemente verstanden und – Heureka! – der Plotter bewegte sich. War am Ende gar nichts kaputt oder nur ein Kabel lose? Das wäre ja der Hammer.

Bei genauerer Betrachtung konnte ich dann aber sehen, was das Problem wirklich war: Die X-Achse, also der Schneidkopf bewegte sich perfekt und gemäß Befehlen, nach links und rechts. Die Y-Achse, also die Walzen, die das Material vor und zurück befördern sollen, bewegten sich zwar auch, aber scheinbar beliebig. Kleine Schritte machten sie gar nicht, erst auf längeren Wegen lief der Motor irgendwann an. Dann aber auch nicht wie er sollte sondern mal nach vorn, mal zurück.

Steppermotor defekt?

Das sah erstmal so aus, als wäre vielleicht der Schrittmotor für diese Achse defekt. Vielleicht eine Wicklung der zwei Motorphasen durchgebrannt oder irgendein Lager im Motor fest? Vielleicht war auch Rost im Inneren des Motors am Stator und/oder am Rotor?

Ich habe also zuerst den Stepper ausgebaut. Zum Glück ging das recht einfach und nur wenige Schrauben waren im Weg. Dann den Stepper geöffnet und optisch geprüft. Rost war es jedenfalls nicht. Vor dem Zusammenbau habe ich alle wichtigen Teile neu geschmiert und den Motor dann im ausgebauten Zustand wieder am Mainboard angeschlossen. Er drehte sich noch immer eher willkürlich.

Ich wollte schon fast einen neuen Stepper bestellen. Hab dann aber doch nochmal einen Blick auf das Mainboard geworfen. Was mir da entgegenkam, war schon erschreckend: Mindestens zwei Kondensatoren auf dem Board waren komplett lose und eins der Beine war jeweils gar nicht mehr verlötet. An anderen Stellen waren mit bloßem Auge kalte oder gebrochene Lötstellen zu sehen. Das das Ding überhaupt mal lief grenzte schon an ein Wunder.

Die schlimmsten Stellen habe ich nachgelötet und vor allem die Treiber alle einmal gründlich gecheckt. Auf dem verbauten Mainboard waren übrigens nicht ein Treiber je Achse verlötet, sondern jeweils zwei PBL3717A. Ein Treiber für jede Phase des Motors. Kannte ich so auch noch nicht diesen Aufbau.

Ich hatte gedacht, man könnte die alten Treiber vielleicht runternehmen und was neueres, vielleicht sogar TMC Treiber drauflöten. Die Pins und Signale sollten ja eigentlich soweit kompatibel sein. Oder nicht? Eine Recherche nach der Teilenummer der Treiber brachte dann Klarheit. Ein kundiger User auf mikrocontroller.net fasste es ganz gut zusammen:

Mal ganz grundsätzlich gefragt: Der PBL3717A ist ein Dinosaurier. Der ist soweit ich weiss noch älter als die beliebte Kombination aus L297 und L298. Die Ansteuerung ist dank der verschiedenen Komparatorstufen nicht kompatibel zu der sonst üblichen Takt-/Richtungssteuerung. Man braucht also immer einen µC. Willst du dir das Ding wirklich antun? Es gibt inzwischen deutlich bessere Treiber, die kaum mehr kosten, aber deutlich weniger Verluste produzieren und deutlich einfacher anzusteuern sind

Quelle

Reparatur: Treiber austauschen

Aha…wie alt ist dieser Plotter eigentlich? Sieht gar nicht so alt aus. Wahrscheinlich ist das Mainboard-Design einfach schon älter und der findige Chinese dachte sich halt “never change a running system”. Inkompatibel war leider ein Wort, was ich nicht lesen wollte. Neue Treiber werden es also wohl nicht. Stattdessen rausfinden, welche defekt sind und Ersatz besorgen.

Lese auch:  DIY Labornetzteil - Teil 1: Komponenten

Leider listen alle Elektronikhändler meines Vertrauens die PBL3717A als ausgelaufen. Bestände sind auch keine mehr vorhanden. Hier und da findet man welche (sogar auf Amazon). Aber bei den Preisen ist es schnell vorbei mit dem vermeintlichen Schnäppchen. Vor allem, wenn noch nicht weiß, welcher Treiber das Problem macht und ob ein Tausch wirklich die Lösung ist.

Am Ende habe ich zum Glück doch noch einen Shop aus England bei eBay gefunden, der die Chips auf Lager hatte und keine Apothekenpreise aufgerufen hat. Dort habe ich zwei neue Treiber bestellt.

Um wirklich sicher zu gehen, dass es an den Treibern liegt, habe ich einfach mal eine Phase vom Stepper getrennt. Also einfach die entsprechenden Pins aus dem Stecker gezogen und nur die anderen beiden angeschlossen. Wie erwartet hat sich bei der einen Phase nicht wirklich was am Fehlerbild geändert. Als nur die andere Verbunden war, drehte sich der Motor gar nicht mehr. Fehler als bestätigt.

Das Auslöten der DIP16 Chips ist leider eine Qual, wenn man keine elektische Entlötpumpe hat. Die in die Jahre gekommene und vermutlich günstig produzierte Platine tat ihr übriges: Durch längere Hitzeeinwirkung – die beim Entlöten so vieler Kontakte leider unvermeidlich ist – lösten sich einige Pads von der Platine. Das Anlöten der neuen Chips wurde so erschwert bis unmöglich.

Zum Glück haben die Designer an einer Stelle nicht gespart: Das Board hatte zwei Sektionen für die Y-Achse. Vermutlich für größere Plotter, die zwei Motoren haben. Dieser Bereich war komplett bestückt, bis auf die Treiber. Damit ich später ggf. leichter einen erneuten Tausch vornehmen kann, habe ich die Chips nicht direkt verlötet, sondern stattdessen einen Sockel montiert und die neuen Treiber da einfach eingesetzt.

Happy End

Wieder alles angeschlossen, Daumen gedrückt und: Es funktioniert! Der Plotter lebt wieder und tut alles, was er soll.

Der Rest war nur noch Kosmetik, ein bisschen Saubermachen, bewegliche Teile schmieren, alles wieder zusammensetzen und ein neuer Messerhalter nebst Plotterklingen. Beides hatte der Verkäufer nicht mitgeschickt. Er hat sich ja laut Auktion ja einen neuen geholt. Hat den alten Messerhalter wohl als Ersatzteil behalten.

Am Ende habe ich also mit Ersatzteilen und dem defekten Gerät von eBay um die 100€ bezahlt und auch gar nicht so viel Zeit investieren müssen. Dafür habe ich jetzt einen funktionierenden Plotter für viele neue Projekte und Ideen und habe auch noch einige Kilo Metall und Plastik vor dem Schrott bewahrt.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.